Optimistic locking errors are detected when flushing to the data store.
SYMPTOMS:
When launching DocAve, the GUI hangs at 95% and the following error displays in the logs: optimistic locking errors were detected when flushing to the data store. The following objects may have been concurrently modified in another transaction.
CAUSE:
This is caused by connection issues with the database.
SOLUTION:
Verify if the No Count option of Default Connection options is selected in the SQL Management Studio property settings. If so, right-click the Control database instance in SQL Server Manager Studio and check Properties. Remove the No Count option of Default Connection options on the Connection page.
Verify that multiple control services are installed and pointing to the same SQL instance. If so, stop the unused control services connecting to the same SQL instance and restart the services on the primary active Manager server.
Option #1 above propogates changes to databases housed under that same instance, so a MS SQL service restart is required.