Error Applying Hotfix

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KB Article ID: 10636

Product: DocAve 6 Suite,Installation
Product Version: 6.0.0.0,6.1.0.0
SharePoint Version: 2010,2010 SP1

Details:

The following error message pops up when applying a hotfix:

Deployed the update to the following service(s) failed: [Service/Agent names], and cannot install the update to these services.  Please reinstall the update.

In the DocAve Control service logs, the follow error can also be found:

ERROR [timestamp information] 26 AvePoint.ControlPanel.service.updateManager.impl.PatchFileService 0- deploy patch error : system.unauthorizedAccessException: Access to the path ‘C:\Program Files\AvePoint\DocAve6\Agent\TempPatchFile\PatchInstaller\Castle.Core.dll’ is denied. 

Cause:

A previous failed attempt at installing a hotfix leaves an existing process and temporary hotfix folder on the location of the intended installation (for example, on the DocAve Agent that the hotfix is being applied).  Access to this existing folder is denied due to the currently existing process.  Process and folder information:

Process: CommonPatchInstaller.exeTemporary hotfix folder: [DocAve Agent/Manager installation directory]\TempPatchFile\

Solution:

  1. Navigate to each location where the hotfix is attempted to be applied (Agent or Manager servers).
  2. Open Windows Task Manager by going to Start > Run and entering taskmgr.
  3. Locate the process CommonPatchInstaller.exe and end this process.  If multiple processes with this name exist, end all instances of this process.
  4. Navigate to the DocAve Agent or Manager installation directory.
  5. Locate the folder titled TempPatchFile and remove this folder.
  6. Repeat steps 1-5 for each location where the hotfix has been attempted to be applied.
  7. After removing all existing CommonPatchInstaller.exe processes and TempPatchFile folders, re-apply the hotfix normally.

*Note: The Agent service must be part of the Local Administrators group in order to properly apply the hotfix.